summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2021-06-03 09:55:00 +0300
committerEli Zaretskii <eliz@gnu.org>2021-06-03 09:55:00 +0300
commit6a152f898dfbc4cd7ece41adf4dc89422262c843 (patch)
tree7363ed94ad306adbabf9df12a63c3bfe2c37e870 /configure.ac
parenta488716961df851bdad767696003327ae5590394 (diff)
downloademacs-6a152f898dfbc4cd7ece41adf4dc89422262c843.tar.gz
* configure.ac: Improve error messages about libgccjit.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 12 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index d99e5395d35..8830e4bed8f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3772,27 +3772,26 @@ AC_DEFUN([libgccjit_smoke_test], [
}]])])
AC_DEFUN([libgccjit_not_found], [
- AC_MSG_ERROR([elisp native compiler requested but libgccjit not found.
-Please try installing libgccjit or similar package.
-If you are sure you want Emacs compiled without elisp native compiler, pass
- --without-native-compilation
-to configure.])])
+ AC_MSG_ERROR([ELisp native compiler was requested, but libgccjit was not found.
+Please try installing libgccjit or a similar package.
+If you are sure you want Emacs be compiled without ELisp native compiler,
+pass the --without-native-compilation option to configure.])])
AC_DEFUN([libgccjit_dev_not_found], [
- AC_MSG_ERROR([elisp native compiler requested but libgccjit header files were
+ AC_MSG_ERROR([ELisp native compiler was requested, but libgccjit header files were
not found.
-Please try installing libgccjit-dev or similar package.
-If you are sure you want Emacs compiled without elisp native compiler, pass
---without-nativecomp
-to configure.])])
+Please try installing libgccjit-dev or a similar package.
+If you are sure you want Emacs be compiled without ELisp native compiler,
+pass the --without-nativecomp option to configure.])])
AC_DEFUN([libgccjit_broken], [
- AC_MSG_ERROR([Installed libgccjit has failed passing the smoke test.
-You can verify it yourself compiling:
+ AC_MSG_ERROR([The installed libgccjit did not pass the smoke test.
+You can verify it yourself by compiling:
<https://gcc.gnu.org/onlinedocs/jit/intro/tutorial01.html>.
Please report the issue to your distribution if libgccjit was installed through
that.
-Here instructions on how to compile and install libgccjit from source:
+You can find the instructions on how to compile and install libgccjit from
+source on this site:
<https://gcc.gnu.org/wiki/JIT>.])])
HAVE_NATIVE_COMP=no