summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrea Corallo <akrl@sdf.org>2020-09-06 08:07:30 +0200
committerAndrea Corallo <akrl@sdf.org>2020-09-06 08:07:30 +0200
commit805563346613af1f13ecd1bf96ffd8efe4816b47 (patch)
tree568434f474dd247c732f096e9e3c6e23c493a1b7 /configure.ac
parent67c53691560616598f746491347bd223480e6172 (diff)
parent669b46e6a39bb5ba5d2ed14baebd585af6130ec9 (diff)
downloademacs-805563346613af1f13ecd1bf96ffd8efe4816b47.tar.gz
Merge remote-tracking branch 'savannah/master' into HEAD
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 16 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 31484db0538..d6584d9852d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1901,8 +1901,7 @@ tmp_CPPFLAGS="$CPPFLAGS"
tmp_CFLAGS="$CFLAGS"
CPPFLAGS="$CPPFLAGS -x objective-c"
CFLAGS="$CFLAGS -x objective-c"
-# Recent versions of GCC don't use C99 to compile Obj-C.
-GNU_OBJC_CFLAGS="-std=c99"
+GNU_OBJC_CFLAGS=""
LIBS_GNUSTEP=
if test "${with_ns}" != no; then
# macfont.o requires macuvs.h which is absent after 'make extraclean',
@@ -1918,7 +1917,7 @@ if test "${with_ns}" != no; then
elif flags=$( (gnustep-config --objc-flags) 2>/dev/null); then
NS_IMPL_GNUSTEP=yes
NS_GNUSTEP_CONFIG=yes
- GNU_OBJC_CFLAGS="$GNU_OBJC_CFLAGS $flags"
+ GNU_OBJC_CFLAGS="$flags"
LIBS_GNUSTEP=$(gnustep-config --gui-libs) || exit
elif test -f $GNUSTEP_CONFIG_FILE; then
NS_IMPL_GNUSTEP=yes
@@ -2068,6 +2067,20 @@ if test "${HAVE_NS}" = yes; then
AC_DEFINE(NATIVE_OBJC_INSTANCETYPE, 1,
[Define if ObjC compiler supports instancetype natively.])
fi
+
+ AC_CACHE_CHECK(
+ [if the Objective C compiler defaults to C99],
+ [emacs_cv_objc_c99],
+ [AC_LANG_PUSH([Objective C])
+ AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM([], [[for (int i = 0;;);]])],
+ emacs_cv_objc_c99=yes,
+ emacs_cv_objc_c99=no)
+ AC_LANG_POP([Objective C])])
+
+ if test x$emacs_cv_objc_c99 = xno ; then
+ GNU_OBJC_CFLAGS="$GNU_OBJC_CFLAGS -std=c99"
+ fi
fi
HAVE_W32=no