summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Third <alan@idiocy.org>2021-04-02 18:06:59 +0100
committerAlan Third <alan@idiocy.org>2021-04-07 09:06:00 +0100
commitc35a515a2f7045f004299f601f6d1927ea16cd47 (patch)
tree26c99f37400e8a721b484a2c08e304f8cedbb53e /configure.ac
parentce15b23846cd82acccb6ce5dd13b0a42f487296b (diff)
downloademacs-c35a515a2f7045f004299f601f6d1927ea16cd47.tar.gz
Fix install with NS app bundle
* configure.ac: Set up CFLAGS and LDFLAGS to find a Homebrew installation of libgccjit. * Makefile.in (ELN_DESTDIR): Set to the app bundle resource dir when required. (install-eln): macOS install doesn't support the -D flag, so make the directories separately.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4284c997141..698e8affb51 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3801,6 +3801,16 @@ if test "${with_native_compilation}" != "no"; then
if test "${HAVE_ZLIB}" = no; then
AC_MSG_ERROR(['--with-nativecomp' requires zlib])
fi
+
+ # Ensure libgccjit installed by Homebrew can be found.
+ if test -n "$BREW"; then
+ BREW_LIBGCCJIT_PREFIX=`$BREW --prefix --installed libgccjit 2>/dev/null`
+ if test "$BREW_LIBGCCJIT_PREFIX"; then
+ CFLAGS="$CFLAGS -I${BREW_LIBGCCJIT_PREFIX}/include"
+ LDFLAGS="$LDFLAGS -L${BREW_LIBGCCJIT_PREFIX}/lib/gcc/10 -I${BREW_LIBGCCJIT_PREFIX}/include"
+ fi
+ fi
+
# Check if libgccjit is available.
AC_CHECK_LIB(gccjit, gcc_jit_context_acquire, [], [libgccjit_not_found])
AC_CHECK_HEADERS(libgccjit.h, [], [libgccjit_dev_not_found])