summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrea Corallo <akrl@sdf.org>2021-02-22 21:01:44 +0100
committerAndrea Corallo <akrl@sdf.org>2021-02-22 21:01:44 +0100
commitcadb902aa8136d9eff8bb0df39daed840c00e1b6 (patch)
tree4969f168b49dccaf27d0ae7b8b06305ddb7ebf4f /configure.ac
parent28ce6f980ff9dc022550933f840ab5c8469cc9d1 (diff)
downloademacs-cadb902aa8136d9eff8bb0df39daed840c00e1b6.tar.gz
Revert "* configure.ac: Rename configure nativecomp flags..."
This reverts commit f6c5f0dd5c8167b6f8f724f42632a4b8808efe7a. Reason for this is that I overlooked few other suggestions and this change has to be discussed before a final decision is taken.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1771171f669..fe0dc921dce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -484,7 +484,7 @@ OPTION_DEFAULT_ON([gnutls],[don't use -lgnutls for SSL/TLS support])
OPTION_DEFAULT_ON([zlib],[don't compile with zlib decompression support])
OPTION_DEFAULT_ON([modules],[don't compile with dynamic modules support])
OPTION_DEFAULT_ON([threads],[don't compile with elisp threading support])
-OPTION_DEFAULT_OFF([native-comp],[compile with Emacs Lisp native compiler support])
+OPTION_DEFAULT_OFF([nativecomp],[compile with Emacs Lisp native compiler support])
AC_ARG_WITH([file-notification],[AS_HELP_STRING([--with-file-notification=LIB],
[use a file notification library (LIB one of: yes, inotify, kqueue, gfile, w32, no)])],
@@ -3786,7 +3786,7 @@ AC_DEFUN([libgccjit_not_found], [
AC_MSG_ERROR([elisp native compiler requested but libgccjit not found.
Please try installing libgccjit or similar package.
If you are sure you want Emacs compiled without elisp native compiler, pass
- --without-native-comp
+ --without-nativecomp
to configure.])])
AC_DEFUN([libgccjit_dev_not_found], [
@@ -3808,7 +3808,7 @@ Here instructions on how to compile and install libgccjit from source:
HAVE_NATIVE_COMP=no
LIBGCCJIT_LIB=
-if test "${with_native_comp}" != "no"; then
+if test "${with_nativecomp}" != "no"; then
if test "${HAVE_PDUMPER}" = no; then
AC_MSG_ERROR(['--with-nativecomp' requires '--with-dumping=pdumper'])
fi