summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Third <alan@idiocy.org>2021-06-26 12:46:43 +0100
committerAlan Third <alan@idiocy.org>2021-06-26 12:48:15 +0100
commitecf7e8b20ea095bd1232175160c3521ee299c069 (patch)
treee34eae20fdfee9f5f4ea76f3a25654b88c70523d /configure.ac
parenta0f060939456f3680823e34f430e482fcde2f5dd (diff)
downloademacs-ecf7e8b20ea095bd1232175160c3521ee299c069.tar.gz
Fix NS self-contained build configuration
* configure.ac: When rebuilding epaths.h for NS check that we're actually doing an NS build first.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 92527056b95..c8920d877e3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6020,12 +6020,12 @@ dnl the use of force in the 'epaths-force' rule in Makefile.in.
AC_CONFIG_COMMANDS([src/epaths.h], [
if test "${opsys}" = "mingw32"; then
${MAKE-make} MAKEFILE_NAME=do-not-make-Makefile epaths-force-w32
-elif test "$EN_NS_SELF_CONTAINED" = "yes"; then
+elif test "$HAVE_NS" = "yes" && test "$EN_NS_SELF_CONTAINED" = "yes"; then
${MAKE-make} MAKEFILE_NAME=do-not-make-Makefile epaths-force-ns-self-contained
else
${MAKE-make} MAKEFILE_NAME=do-not-make-Makefile epaths-force
fi || AC_MSG_ERROR(['src/epaths.h' could not be made.])
-], [GCC="$GCC" CPPFLAGS="$CPPFLAGS" opsys="$opsys"
+], [GCC="$GCC" CPPFLAGS="$CPPFLAGS" opsys="$opsys" HAVE_NS="$HAVE_NS"
EN_NS_SELF_CONTAINED="$EN_NS_SELF_CONTAINED"])
dnl NB we have to cheat and use the ac_... version because abs_top_srcdir