summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPo Lu <luangruo@yahoo.com>2023-08-18 08:20:30 +0800
committerPo Lu <luangruo@yahoo.com>2023-08-18 08:20:53 +0800
commit02d96e39b2182660e61e85b7b07da14ba6d94210 (patch)
treefe81b02b73837457f883f9b30f03b2ffd839f6d2 /configure.ac
parent3685387e609753293c4518be75e77c659c3b2d8d (diff)
downloademacs-02d96e39b2182660e61e85b7b07da14ba6d94210.tar.gz
Don't disable terminfo on non-GUI Android builds
* configure.ac (TERMINFO, LIBS_TERMCAP): Clear only if REALLY_ANDROID. (bug#65340)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4cf6751ab82..f92339225b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6030,7 +6030,7 @@ TERMINFO=yes
## LIBS_TERMCAP="-lncurses", this overrides LIBS_TERMCAP = -ltinfo,
## if that was found above to have tputs.
## Should we use the gnu* logic everywhere?
-case "$opsys" in
+case "$opsys$REALLY_ANDROID" in
## darwin: Prevents crashes when running Emacs in Terminal.app under 10.2.
## The ncurses library has been moved out of the System framework in
## Mac OS X 10.2. So if configure detects it, set the command-line
@@ -6059,7 +6059,10 @@ fail;
fi
;;
- mingw32 | android)
+ # The case condition is a concatenation of both $opsys and
+ # $REALLY_ANDROID. Only disable termcap if building a GUI program.
+ # (bug#65340)
+ mingw32 | androidyes)
TERMINFO=no
LIBS_TERMCAP=
;;