summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrea Corallo <acorallo@gnu.org>2023-12-13 12:22:39 +0100
committerAndrea Corallo <acorallo@gnu.org>2023-12-13 12:25:23 +0100
commit281a16d15fad5b05d88d03e2f4c9718c81657840 (patch)
tree27fa6d5a8ff37d9c17411656f45eecc3c266c815 /configure.ac
parent75fd7550ed6cede6c9e8224f1f2d62637c43fdd4 (diff)
downloademacs-281a16d15fad5b05d88d03e2f4c9718c81657840.tar.gz
* configure.ac: Fix '--without-all' if libgccjit installed (bug#67799)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a279f78a0ea..0224c9c32eb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5149,6 +5149,11 @@ source on this site:
with_native_compilation=no])
+if test "$with_features" = "no" \
+ && test "${with_native_compilation}" = "default"; then
+ with_native_compilation=no
+fi
+
if test "${with_native_compilation}" = "default"; then
# Check if libgccjit is available.
AC_CHECK_LIB([gccjit], [gcc_jit_context_acquire],