summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPo Lu <luangruo@yahoo.com>2023-08-09 09:19:11 +0800
committerPo Lu <luangruo@yahoo.com>2023-08-09 09:48:32 +0800
commit3f2e009ac3352f9384a3f560bf2505223f607913 (patch)
tree67fb917097606f080e9544afcf918cd767275e3b /configure.ac
parentaf907c060a08e6eb87de595552e0fb4ca6aeed83 (diff)
downloademacs-3f2e009ac3352f9384a3f560bf2505223f607913.tar.gz
; Minor adjustments to configury, loaddefs and gitignore
* .gitignore: Add exec/aclocal.m4. * configure.ac (bitmapdirs): Circumvent shell substitution that isn't supported by the Bourne shell. * lisp/ldefs-boot.el: Update from loaddefs.el.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index de602371f7b..6e080c1c666 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2762,16 +2762,16 @@ if test x"${x_includes}" = x; then
bitmapdir=/usr/include/X11/bitmaps
else
# accumulate include directories that have X11 bitmap subdirectories
- bmd_acc=
+ AS_UNSET([bmd_acc])
for bmd in `AS_ECHO(["$x_includes"]) | sed -e 's/:/ /g'`; do
if test -d "${bmd}/X11/bitmaps"; then
- bmd_acc="${bmd_acc}:${bmd}/X11/bitmaps"
+ bmd_acc="${bmd_acc+$bmd_acc:}${bmd}/X11/bitmaps"
fi
if test -d "${bmd}/bitmaps"; then
- bmd_acc="${bmd_acc}:${bmd}/bitmaps"
+ bmd_acc="${bmd_acc+$bmd_acc:}${bmd}/bitmaps"
fi
done
- bitmapdir=${bmd_acc#:}
+ bitmapdir=$bmd_acc
fi
NATIVE_IMAGE_API=no