summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPo Lu <luangruo@yahoo.com>2023-09-06 11:19:32 +0800
committerPo Lu <luangruo@yahoo.com>2023-09-06 11:19:38 +0800
commit4ec4b18c2a064a8a747fd381765b26cdf1b077f5 (patch)
tree400513e29e0c256f1bbcf5d019ce204b930c1e37 /configure.ac
parent80bdcf8f351f35f1eb73a016f7e58188be0425d4 (diff)
downloademacs-4ec4b18c2a064a8a747fd381765b26cdf1b077f5.tar.gz
Fix libgccjit build on Haiku
* configure.ac (LIBGCCJIT_LIBS): Link only with -lgccjit under Haiku.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ab401be1c1d..a4986c7a43c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4385,8 +4385,9 @@ if test "${with_native_compilation}" != "no"; then
case "${opsys}" in
# mingw32 loads the library dynamically.
mingw32) ;;
- # OpenBSD doesn't have libdl, all the functions are in libc
- netbsd|openbsd)
+ # Neither NetBSD, OpenBSD nor Haiku have libdl, with all dynamic
+ # linker functions placed within libc.
+ netbsd|openbsd|haiku)
LIBGCCJIT_LIBS="-lgccjit" ;;
darwin)
LIBGCCJIT_CFLAGS="${MAC_CFLAGS}"