summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Monnier <monnier@iro.umontreal.ca>2023-09-30 09:42:02 -0400
committerStefan Monnier <monnier@iro.umontreal.ca>2023-09-30 09:42:02 -0400
commit63ddbcc0225bb888a82a3759abb7a5c64513e752 (patch)
tree07e7244c0fbb5a93bc823f4a147ad554fbfff3ae /configure.ac
parentf7fd21b06865d20a16c11e20776e843db24d4b14 (diff)
parent8db48d247b7fedab0aa1b2d8573ccc2b950ad545 (diff)
downloademacs-63ddbcc0225bb888a82a3759abb7a5c64513e752.tar.gz
Merge remote-tracking branch 'refs/remotes/origin/master'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 6eb6d297987..9ae0dec3867 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1664,13 +1664,13 @@ AC_ARG_ENABLE([gcc-warnings],
# however, if there is also a .tarball-version file it is probably
# just a release imported into Git for patch management.
gl_gcc_warnings=no
- if test -e "$srcdir"/.git && test ! -f "$srcdir"/.tarball-version; then
- # Clang typically identifies itself as GCC 4.2 or something similar
- # even if it is recent enough to accept the warnings we enable.
- AS_IF([test "$emacs_cv_clang" = yes],
- [gl_gcc_warnings=warn-only],
- [gl_GCC_VERSION_IFELSE([5], [3], [gl_gcc_warnings=warn-only])])
- fi])
+ AS_IF([test -d "$srcdir"/.git || test -f "$srcdir"/.git],
+ [AS_IF([test -f "$srcdir"/.tarball-version], [],
+ # Clang typically identifies itself as GCC 4.2 or something similar
+ # even if it is recent enough to accept the warnings we enable.
+ [AS_IF([test "$emacs_cv_clang" = yes],
+ [gl_gcc_warnings=warn-only],
+ [gl_GCC_VERSION_IFELSE([5], [3], [gl_gcc_warnings=warn-only])])])])])
NATIVE_COMPILATION_AOT=no
AC_ARG_WITH([native-compilation],