summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPo Lu <luangruo@yahoo.com>2023-09-07 09:35:59 +0800
committerPo Lu <luangruo@yahoo.com>2023-09-07 09:35:59 +0800
commit8b25edfbda6ed8973b483f700571e00a60f27002 (patch)
tree994ff56260b8f6d582400ac511ee42f0cfa8af3e /configure.ac
parent241616831024c9c9fe2b2378b611db0a560b9675 (diff)
downloademacs-8b25edfbda6ed8973b483f700571e00a60f27002.tar.gz
Port Proced to Android
* configure.ac (HAVE_PROCFS): Define if opsys is `android'. * src/android.c (android_set_task_name): New function. (android_run_select_thread, android_run_debug_thread): Set the name of the LWP for debugging purposes. * src/process.c (create_process): Set F_SETPIPE_SZ on Android in addition to GNU/Linux. * src/sysdep.c (procfs_ttyname, system_process_attributes) [__ANDROID__]: Enable procfs_ttyname on Android systems.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f92339225b5..ee13b2e0659 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6513,7 +6513,7 @@ case $opsys in
esac
case $opsys in
- gnu-* | solaris | cygwin )
+ gnu-* | android | solaris | cygwin )
dnl FIXME Can't we test if this exists (eg /proc/$$)?
AC_DEFINE([HAVE_PROCFS], [1], [Define if you have the /proc filesystem.])
;;