summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2023-08-10 11:44:49 +0300
committerEli Zaretskii <eliz@gnu.org>2023-08-10 11:44:49 +0300
commitf2e3d2f1256da2a551cfe3fa685e582eb6d09d60 (patch)
tree4edef90494c957c2ebb93fcfe4734b32fc9ceca3 /configure.ac
parent49248878d4da7dbf901a7cd555e129803ac5e095 (diff)
downloademacs-f2e3d2f1256da2a551cfe3fa685e582eb6d09d60.tar.gz
Streamline definition of BOOT_TIME_FILE on MS-Windows
* nt/inc/ms-w32.h: Don't define BOOT_TIME_FILE here... * configure.ac: ...define it here instead, as for the other systems.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0bc0de1bfac..0236dbd89d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2643,6 +2643,17 @@ AC_CACHE_CHECK([for old but post-boot file],
do
test -f $file && { emacs_cv_boot_time_file=$file; break; }
done])],
+ # This isn't perfect, as some systems might have the page file in
+ # another place. Also, I suspect that the time stamp of that
+ # file might also change when Windows enlarges the file due to
+ # insufficient VM. Still, this seems to be the most reliable
+ # way; the alternative (of using GetSystemTimes) won't work on
+ # laptops that hibernate, because the system clock is stopped
+ # then. Other possibility would be to run "net statistics
+ # workstation" and parse the output, but that's gross. So this
+ # should do; if the file is not there, the boot time will be
+ # returned as zero, and filelock.c already handles that.
+ [mingw32], [emacs_cv_boot_time_file=C:/pagefile.sys],
[*], [emacs_cv_boot_time_file=not-needed])])
AS_CASE([$emacs_cv_boot_time_file],