summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPo Lu <luangruo@yahoo.com>2023-08-16 20:32:04 +0800
committerPo Lu <luangruo@yahoo.com>2023-08-16 20:32:38 +0800
commitf2f2e6a082a541c60eb25ad6d30707e111082811 (patch)
tree5025a94d03771c88061af5e831650e8adc8b2a9f /configure.ac
parent22d031f644d38e385f422ffc4855385d9052659b (diff)
downloademacs-f2f2e6a082a541c60eb25ad6d30707e111082811.tar.gz
Update Android port
* configure.ac: Test for getpwent using gl_CHECK_FUNCS_ANDROID. (bug#65319) * etc/MACHINES (Android): Mention that a non-GUI build is also possible on Android. * lisp/loadup.el: Provide for regular builds on Android. (bug#65339) * lisp/wid-edit.el (widget-event-start): Remove function, since event-start now does the same thing. (widget-button--check-and-call-button, widget-button-click): Adjust correspondingly. Reported by Stefan Monnier <monnier@iro.umontreal.ca>. * src/sysdep.c (close_output_streams): Apply workarounds for the file descriptor sanitizer on all builds where __ANDROID__ is defined, not just Android port builds. (bug#65340)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 46347a12050..8120935978d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5846,11 +5846,14 @@ getrlimit setrlimit shutdown \
pthread_sigmask strsignal setitimer \
sendto recvfrom getsockname getifaddrs freeifaddrs \
gai_strerror sync \
-getpwent endpwent getgrent endgrent \
+endpwent getgrent endgrent \
renameat2 \
cfmakeraw cfsetspeed __executable_start log2 pthread_setname_np \
pthread_set_name_np])
+# getpwent is not present in older versions of Android. (bug#65319)
+gl_CHECK_FUNCS_ANDROID([getpwent], [[#include <pwd.h>]])
+
if test "$ac_cv_func_cfmakeraw" != "yes"; then
# On some systems (Android), cfmakeraw is inline, so AC_CHECK_FUNCS
# cannot find it. Check if some code including termios.h and using