summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYuan Fu <casouri@gmail.com>2022-11-10 00:31:10 -0800
committerYuan Fu <casouri@gmail.com>2022-11-10 00:31:10 -0800
commit77cb95c851edc338c94cb35effdc8c9ffc64a461 (patch)
treeef3556cfa3b69b03cf4314b5a8f9cc973613b7bc /configure.ac
parenteecc2d45b94513ba95789dfe0ef58aeb8b029049 (diff)
downloademacs-77cb95c851edc338c94cb35effdc8c9ffc64a461.tar.gz
; Revert back to requiring tree-sitter v0.0 for now
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c5f2be64399..caf3366cfd5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3217,7 +3217,11 @@ TREE_SITTER_OBJ=
if test "${with_tree_sitter}" != "no"; then
dnl Tree-sitter 0.20.2 added support to change the malloc it uses
dnl at runtime.
- EMACS_CHECK_MODULES([TREE_SITTER], [tree-sitter >= 0.20.2],
+ dnl
+ dnl Tree-sitter's Makefile has problems, until that's fixed,
+ dnl tree-sitter libraries will be versioned 0.6.3. So for now
+ dnl require 0.0.
+ EMACS_CHECK_MODULES([TREE_SITTER], [tree-sitter >= 0.0],
[HAVE_TREE_SITTER=yes], [HAVE_TREE_SITTER=no])
if test "${HAVE_TREE_SITTER}" = yes; then
AC_DEFINE(HAVE_TREE_SITTER, 1, [Define if using tree-sitter.])