summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Kangas <stefankangas@gmail.com>2023-03-20 06:30:30 +0100
committerStefan Kangas <stefankangas@gmail.com>2023-03-20 06:30:30 +0100
commitc194a31fc4581125afa202e1641e3f2f54cd98bd (patch)
tree4400a703f7fcc8210ab16431dbd137ebe6d3aa21 /configure.ac
parent32bfeaf007046b8cdba2dd5aa5f5a556652ccb23 (diff)
parent028f11027384b6fb6807ea4057073e3be4003e9e (diff)
downloademacs-c194a31fc4581125afa202e1641e3f2f54cd98bd.tar.gz
Merge from origin/emacs-29
028f1102738 Fix quoting of font-family in 'hfy-family' 4cb8a850b08 ; Tweak doc/misc/eglot.texi d5d4959ed7d Document how to construct JSONRPC arrays in Eglot manual 078cf512eef * test/infra/Dockerfile.emba: Use debian:bullseye. 61adb44318a * configure.ac: Fix native comp compatibility check (bug#... d814c249f44 * test/infra/Dockerfile.emba: Install clangd. 27edd7f88cb Remove 'package-vc--query-spec' 39fea115515 Do not store :lisp-dir in package descriptors 168165178f3 Use 'package-vc-selected-packages' to store package specs
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 25afe3a6981..c5300beb2ba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4289,8 +4289,8 @@ If you really want to try it anyway, use the configure option
fi
if test "${with_native_compilation}" != "no"; then
- if test "${HAVE_PDUMPER}" = no; then
- AC_MSG_ERROR(['--with-native-compilation' requires '--with-dumping=pdumper'])
+ if test "$with_unexec" = yes; then
+ AC_MSG_ERROR(['--with-native-compilation' is not compatible with unexec])
fi
if test "${HAVE_ZLIB}" = no; then
AC_MSG_ERROR(['--with-native-compilation' requires zlib])