summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPo Lu <luangruo@yahoo.com>2022-12-04 20:01:31 +0800
committerPo Lu <luangruo@yahoo.com>2022-12-04 20:02:32 +0800
commitf96a9e10b108237e4aa192eca962ceb0ca07e431 (patch)
tree202bbdb3f6dc79f100cae61cd97b65f698aa5321 /configure.ac
parentbe67cc276a95a97a329fa633fef686ba06c8e6d2 (diff)
downloademacs-f96a9e10b108237e4aa192eca962ceb0ca07e431.tar.gz
Make Emacs build with Xfixes support on old versions of the library
* src/xterm.c (xfixes_toggle_visible_pointer): (x_toggle_visible_pointer): (XTtoggle_invisible_pointer, x_term_init): Disable code requiring fixes 4.0 or later when the fixes library is older. * src/xterm.h: Define missing types needed by other extensions when the fixes library is too old. * configure.ac: Allow building with any version of the Xfixes extension library.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b5867cf839e..9f431fc78b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4704,7 +4704,7 @@ AC_SUBST([XINERAMA_LIBS])
### Use Xfixes (-lXfixes) if available
HAVE_XFIXES=no
if test "${HAVE_X11}" = "yes"; then
- XFIXES_REQUIRED=4.0.0
+ XFIXES_REQUIRED=1.0.0
XFIXES_MODULES="xfixes >= $XFIXES_REQUIRED"
EMACS_CHECK_MODULES([XFIXES], [$XFIXES_MODULES])
if test $HAVE_XFIXES = no; then