summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLars Ingebrigtsen <larsi@gnus.org>2019-11-17 19:02:54 +0100
committerLars Ingebrigtsen <larsi@gnus.org>2019-11-17 19:02:54 +0100
commit3fdc36eecb3ab468eb0a55cc09a176ab503d31c3 (patch)
treeadcef10f0a4e7283ed9f9c737f5e7fb06604943a /configure.ac
parent1c29ba034092660e73bce8c6ff459c75ff2c2d72 (diff)
downloademacs-3fdc36eecb3ab468eb0a55cc09a176ab503d31c3.tar.gz
Error out on --with-harfbuzz without HarfBuzz support
* configure.ac: Error out if the user says --with-harfbuzz, but HarfBuzz isn't available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3b6a2a6d167..0976b665e66 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3469,6 +3469,11 @@ if test "${HAVE_X11}" = "yes" && test "${HAVE_FREETYPE}" = "yes" \
fi
fi
+# The user explicitly asked for HarfBuzz, but it won't be used.
+if test "${with_harfbuzz}" == "yes" && test "$HAVE_HARFBUZZ" != "yes"; then
+ AC_MSG_ERROR([HarfBuzz wanted, but won't be used. Maybe some library files are missing?]);
+fi
+
### End of font-backend section.
AC_SUBST(FREETYPE_CFLAGS)