summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Pluim <rpluim@gmail.com>2020-01-24 10:37:59 +0100
committerRobert Pluim <rpluim@gmail.com>2020-01-24 10:46:00 +0100
commit1ebe1605775c0f273957c1541d5b526bb70f7cfb (patch)
tree4825d50c0f37ec8f552025aef1f35ed0cf98ac0d /configure.ac
parent75c1f936fcff109e19be4abdcddd9fa2204fabca (diff)
downloademacs-1ebe1605775c0f273957c1541d5b526bb70f7cfb.tar.gz
Warn about XFT and about Cairo without HarfBuzz
* configure.ac: Warn about libXFT usage. Warn about using Cairo without HarfBuzz. * etc/NEWS: Announce XFT and HarfBuzz warnings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d7b4d0352cc..932142d813a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5891,6 +5891,20 @@ you can continue to support by using '$0 --with-pop'.])
esac
fi
+if test "${HAVE_XFT}" = yes; then
+AC_MSG_WARN([This configuration uses libXft,
+ which has a number of font rendering issues, and is being considered for
+ removal in the next release of Emacs. Please consider using Cairo + HarfBuzz
+ instead (they are auto-detected if the relevant development headers are
+ installed).])
+fi
+
+if test "${HAVE_CAIRO}" = "yes" && test "${HAVE_HARFBUZZ}" = no; then
+ AC_MSG_WARN([This configuration uses Cairo, but not HarfBuzz. We
+ recommend the use of HarfBuzz when using Cairo, please install
+ HarfBuzz development packages.])
+fi
+
# Let plain 'make' work.
test "$MAKE" = make || test -f makefile || cat >makefile <<EOF
.POSIX: