summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2021-05-20 11:26:00 +0300
committerEli Zaretskii <eliz@gnu.org>2021-05-20 11:26:00 +0300
commitb2eed2ae568b53ac910f4a3b8458eedf8d8c67ec (patch)
treebff25c6d02605018e916b904ef77454812ca0f64 /configure.ac
parentd68f2b8681f8eeb6bbf1b4476a88f00b2962179e (diff)
downloademacs-b2eed2ae568b53ac910f4a3b8458eedf8d8c67ec.tar.gz
Clean up the fix for unexec build on GNU/Linux
* src/conf_post.h [HYBRID_MALLOC || DARWIN_OS && HAVE_UNEXEC]: Include <stdlib.h> here, before redirecting 'malloc' and friends to their hybrid_* and unexec_* equivalents. #undef malloc and friends before redefining. Provide prototypes for the replacements. Suggested by Paul Eggert <eggert@cs.ucla.edu>. * src/gmalloc.c [HYBRID_MALLOC]: Remove declarations of 'malloc' and friends, as they are now redundant: we include <stdlib.h> in conf_post.h before redefining 'malloc' etc., and that provides prototypes from system headers. * configure.ac (HYBRID_MALLOC): Remove kludge to avoid replacement of 'free' by Gnulib. (Bug#36649)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 0 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index d35ac6dbd37..d99e5395d35 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2309,9 +2309,6 @@ elif test "$hybrid_malloc" = yes; then
GNU_MALLOC_reason=" (only before dumping)"
GMALLOC_OBJ=gmalloc.o
VMLIMIT_OBJ=
- # FIXME: This is to prevent Gnulib from redirecting 'free' to its
- # replacement, instead of 'hybrid_free' in gmalloc.c.
- gl_cv_func_free_preserves_errno=yes
else
test "$doug_lea_malloc" != "yes" && GMALLOC_OBJ=gmalloc.o
VMLIMIT_OBJ=vm-limit.o