summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Oliver <git@mavit.org.uk>2021-06-22 15:17:28 +0200
committerLars Ingebrigtsen <larsi@gnus.org>2021-06-22 15:17:28 +0200
commit57ec4aadc65389f6df5a173cfbff0a551b3ee25d (patch)
tree84c599b97cddf3d0a5c3a671e5532326ae3633ff /configure.ac
parent00501d74d3f9642e69b96bcfdb0cc9228d71aa3b (diff)
downloademacs-57ec4aadc65389f6df5a173cfbff0a551b3ee25d.tar.gz
Advertise support for Startup Notification when built with GTK
* etc/emacsclient.desktop, etc/emacsclient.desktop: Specify StartupNotify=true. * configure.ac (USE_STARTUP_NOTIFICATION): New variable, yes iff HAVE_GTK. * Makefile.in (install-etc): Remove StartupNotify=true from etc/*.desktop unless USE_STARTUP_NOTIFICATION (bug#48783).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c828f8d7828..830f33844b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2892,6 +2892,11 @@ fi
AC_SUBST(SETTINGS_CFLAGS)
AC_SUBST(SETTINGS_LIBS)
+USE_STARTUP_NOTIFICATION=no
+if test "${HAVE_GTK}" = "yes"; then
+ USE_STARTUP_NOTIFICATION=yes
+fi
+AC_SUBST(USE_STARTUP_NOTIFICATION)
dnl SELinux is available for GNU/Linux only.
HAVE_LIBSELINUX=no