summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLars Ingebrigtsen <larsi@gnus.org>2022-10-03 12:45:21 +0200
committerLars Ingebrigtsen <larsi@gnus.org>2022-10-03 12:45:21 +0200
commite245c4f226979ccb717cccc8f82b2b0a0f96bdac (patch)
treeef67fff370632f4950dd3924b56a6445ee249619 /configure.ac
parent450d94920f5abc36167beb02be909ff65a7f4111 (diff)
downloademacs-e245c4f226979ccb717cccc8f82b2b0a0f96bdac.tar.gz
Add --with-native-compilation=aot configuration option
* configure.ac: Allow --with-native-compilation=aot to switch full ahead-of-time on. * lisp/Makefile.in: Use the setting from configure.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 23 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4590ed3506e..2d843440503 100644
--- a/configure.ac
+++ b/configure.ac
@@ -494,7 +494,6 @@ OPTION_DEFAULT_ON([gnutls],[don't use -lgnutls for SSL/TLS support])
OPTION_DEFAULT_ON([zlib],[don't compile with zlib decompression support])
OPTION_DEFAULT_ON([modules],[don't compile with dynamic modules support])
OPTION_DEFAULT_ON([threads],[don't compile with elisp threading support])
-OPTION_DEFAULT_OFF([native-compilation],[compile with Emacs Lisp native compiler support])
OPTION_DEFAULT_OFF([cygwin32-native-compilation],[use native compilation on 32-bit Cygwin])
OPTION_DEFAULT_ON([xinput2],[don't use version 2 of the X Input Extension for input])
OPTION_DEFAULT_OFF([small-ja-dic],[generate a smaller-size Japanese dictionary])
@@ -1009,6 +1008,29 @@ AC_ARG_ENABLE([gcc-warnings],
[gl_GCC_VERSION_IFELSE([5], [3], [gl_gcc_warnings=warn-only])])
fi])
+NATIVE_COMPILATION_AOT=no
+AC_ARG_WITH([native-compilation],
+ [AS_HELP_STRING([--with-native-compilation@<:@=TYPE@:>@],
+ [compile with Emacs Lisp native compiler support. The TYPE
+ 'yes' (or empty) means to enable it and compile natively
+ preloaded Lisp files; 'no' means to disable it;
+ 'aot' will make the build process compile all the Lisp
+ files in the tree natively ahead of time. (This will
+ usually be quite slow.)])],
+ [
+ case $withval in
+ aot)
+ withval=yes
+ NATIVE_COMPILATION_AOT=yes
+ ;;
+ yes|no) ;;
+ *) AC_MSG_ERROR([bad value $withval for native-compilation option]) ;;
+ esac
+ with_native_compilation=$withval],
+ [with_native_compilation=no]
+)
+AC_SUBST([NATIVE_COMPILATION_AOT])
+
AC_ARG_ENABLE([check-lisp-object-type],
[AS_HELP_STRING([--enable-check-lisp-object-type],
[Enable compile time checks for the Lisp_Object data type,