summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLars Ingebrigtsen <larsi@gnus.org>2021-12-11 06:40:01 +0100
committerLars Ingebrigtsen <larsi@gnus.org>2021-12-11 06:40:01 +0100
commitebf59d1a28b49b391b8025d7017bacf853c01aa2 (patch)
treec1e91846fd6a916e7013bb1d596d318f5b79a556 /configure.ac
parentad1b80d91dfae992c91d36446af5357f77739bfc (diff)
downloademacs-ebf59d1a28b49b391b8025d7017bacf853c01aa2.tar.gz
Check whether the sqlite supports sqlite3_load_extension
* configure.ac: Check for sqlite3_load_extension, which is apparently missing in some versions. * src/sqlite.c: Add guards. (Fsqlite_load_extension): Ifdef out on systems that doesn't have it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5eb23849b53..8d15c70d847 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2695,6 +2695,11 @@ if test "${with_sqlite3}" != "no"; then
if test "${opsys}" = "mingw32"; then
SQLITE3_LIBS=
fi
+ AC_CHECK_LIB(sqlite3, sqlite3_load_extension,
+ HAVE_SQLITE3_LOAD_EXTENSION=yes, HAVE_SQLITE3_LOAD_EXTENSION=no)
+ if test "$HAVE_SQLITE3_LOAD_EXTENSION" = "yes"; then
+ AC_DEFINE(HAVE_SQLITE3_LOAD_EXTENSION, 1, [Define to 1 if sqlite3 supports loading extensions.])
+ fi
fi
fi