summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@fb.com>2022-06-26 21:26:01 -0700
committerEli Zaretskii <eliz@gnu.org>2022-06-28 14:27:55 +0300
commit0b62ad2f3a57845c664965658da82ffc93cb6e26 (patch)
treec69573c0deafc481a06324095e1ca39af58f79ce /configure.ac
parentf5293b336478ca48052b6a4b1538de45446317f4 (diff)
downloademacs-0b62ad2f3a57845c664965658da82ffc93cb6e26.tar.gz
Fix configure.ac quoting of AC_CHECK_LIB's 2nd arg
Running an autoconf-head-generated configure, would fail like this: /emacs/configure: line 18002: syntax error near unexpected token `;;' /emacs/configure: line 18002: ` ;;' That is due to under-quoting of AC_CHECK_LIB's second argument, which led to the comma in an embedded string being interpreted as paramater-delimiting. * configure.ac: Quote the second arg of each AC_CHECK_LIB invocation. (Bug#56272) Copyright-paperwork-exempt: yes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c91b7de322a..17f86627a7d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3622,7 +3622,7 @@ if test "${HAVE_X11}" = "yes"; then
CFLAGS="$CFLAGS $XFT_CFLAGS"
LIBS="$XFT_LIBS $LIBS"
AC_CHECK_HEADER(X11/Xft/Xft.h,
- AC_CHECK_LIB(Xft, XftFontOpen, HAVE_XFT=yes, , $XFT_LIBS) , ,
+ [AC_CHECK_LIB(Xft, XftFontOpen, HAVE_XFT=yes, , $XFT_LIBS)] , ,
[[#include <X11/X.h>]])
if test "${HAVE_XFT}" = "yes"; then
@@ -3818,7 +3818,7 @@ AC_SUBST(M17N_FLT_LIBS)
XCB_LIBS=
if test "${HAVE_X11}" = "yes"; then
AC_CHECK_HEADER(X11/Xlib-xcb.h,
- AC_CHECK_LIB(xcb, xcb_translate_coordinates, HAVE_XCB=yes))
+ [AC_CHECK_LIB(xcb, xcb_translate_coordinates, HAVE_XCB=yes)])
if test "${HAVE_XCB}" = "yes"; then
AC_CHECK_LIB(X11-xcb, XGetXCBConnection, HAVE_X11_XCB=yes)
if test "${HAVE_X11_XCB}" = "yes"; then
@@ -4597,7 +4597,7 @@ XSYNC_CFLAGS=
HAVE_XSYNC=no
if test "${HAVE_X11}" = "yes"; then
AC_CHECK_HEADER(X11/extensions/sync.h,
- AC_CHECK_LIB(Xext, XSyncQueryExtension, HAVE_XSYNC=yes),
+ [AC_CHECK_LIB(Xext, XSyncQueryExtension, HAVE_XSYNC=yes)],
[], [#include <X11/Xlib.h>])
if test "${HAVE_XSYNC}" = "yes"; then