summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Kangas <stefankangas@gmail.com>2023-03-09 06:30:23 +0100
committerStefan Kangas <stefankangas@gmail.com>2023-03-09 06:30:23 +0100
commit5056b8e589753698ce7ee935980ca03de0e41bf5 (patch)
treed02cb9bd739b5caa7bc6d57047e07d6012d112c5 /configure.ac
parentda4f1fa550f753e76c611b313d4f00987daed5ad (diff)
parent7e1012765c40a10a8a051c39566778913dc7e224 (diff)
downloademacs-5056b8e589753698ce7ee935980ca03de0e41bf5.tar.gz
Merge from origin/emacs-29
7e1012765c4 Fix libwebp check for some webp installations c2ca009da4c Avoid potential infloop 34c14430e9d Don't misindent 'else:' after 'if re.match:' in Python 8a2a554192a * Make sure `default-directory' exists before spawning pr... 1862e7eb7ef Fix sed expression in install-etc make target c8ec0017cb9 Avoid using bash in the emacsclient desktop file a588937094f Fix documentation of the 'line-height' text property 971ded31c4f Add 'declare' specs to with- and without-restriction
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b484ebdc8ba..25afe3a6981 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2776,6 +2776,25 @@ if test "${with_webp}" != "no"; then
WEBP_MODULE="libwebpdemux >= $WEBP_REQUIRED"
EMACS_CHECK_MODULES([WEBP], [$WEBP_MODULE])
+
+ # WebPGetInfo is sometimes not present inside libwebpdemux, so
+ # if it does not link, also check for libwebpdecoder.
+
+ OLD_CFLAGS=$CFLAGS
+ OLD_LIBS=$LIBS
+ CFLAGS="$CFLAGS $WEBP_CFLAGS"
+ LIBS="$LIBS $WEBP_LIBS"
+
+ AC_CHECK_FUNC([WebPGetInfo], [],
+ [WEBP_MODULE="$WEBP_MODULE libwebpdecoder >= $WEBP_REQUIRED"
+ HAVE_WEBP=no
+ AS_UNSET([WEBP_LIBS])
+ AS_UNSET([WEBP_CFLAGS])
+ EMACS_CHECK_MODULES([WEBP], [$WEBP_MODULE])])
+
+ CFLAGS=$OLD_CFLAGS
+ LIBS=$OLD_LIBS
+
AC_SUBST([WEBP_CFLAGS])
AC_SUBST([WEBP_LIBS])
fi