summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2020-03-29 16:43:56 +0300
committerEli Zaretskii <eliz@gnu.org>2020-03-29 16:43:56 +0300
commit1276c8e10b000b571a12227ebe9216cc6305ef7f (patch)
tree13bcb10e23d52fb2edb09e863fc003e0c9da0231 /configure.ac
parent76b3bd8cbb9a0a01941d9c1766c054960e4bfd97 (diff)
downloademacs-1276c8e10b000b571a12227ebe9216cc6305ef7f.tar.gz
Use hard links to Emacs executable in "make install" on MS-Windows
* configure.ac (LN_S_FILEONLY): Set to "/bin/ln" for MinGW unconditionally.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 5 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index a4daf1414d3..9907160482e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1246,18 +1246,12 @@ emacs_cv_ln_s_fileonly='cp -p'
dnl On MinGW, ensure we will call the MSYS /bin/ln.exe, not some
dnl random program in the current directory.
if (echo >conf$$.file) 2>/dev/null; then
- if ln -s conf$$.file conf$$ 2>/dev/null; then
- if test "$opsys" = "mingw32"; then
- emacs_cv_ln_s_fileonly='/bin/ln -s'
- else
- emacs_cv_ln_s_fileonly='ln -s'
- fi
+ if test "$opsys" = "mingw32"; then
+ emacs_cv_ln_s_fileonly=/bin/ln
+ elif ln -s conf$$.file conf$$ 2>/dev/null; then
+ emacs_cv_ln_s_fileonly='ln -s'
elif ln conf$$.file conf$$ 2>/dev/null; then
- if test "$opsys" = "mingw32"; then
- emacs_cv_ln_s_fileonly=/bin/ln
- else
- emacs_cv_ln_s_fileonly=ln
- fi
+ emacs_cv_ln_s_fileonly=ln
fi
fi