summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2020-08-05 17:36:50 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2020-08-05 17:38:41 -0700
commit155b2c8a8d51a492a8c350b92bd3e83187d72b78 (patch)
tree4cbb7f487fa85232f216662a71caa202e95899d1 /configure.ac
parent1a99697b4d8c11a10d5e6a306103740d92cc08a1 (diff)
downloademacs-155b2c8a8d51a492a8c350b92bd3e83187d72b78.tar.gz
Simplify Solaris port
This should avoid some configuration confusion as exemplified by Jeffrey Walton’s recent bug report (Bug#42675). * configure.ac (opsys): Simplify Solaris configuration by not worrying about Solaris 9 and earlier, as they are no longer supported by the Solaris developers. This should support Walton’s ‘./configure --build=x86_64-sun-solaris’. Instead of bothering with ‘opsys=sol2-6’ and ‘opsys=sol2-10’, just use ‘opsys=solaris’. All uses changed. (emacs_check_sunpro_c): Remove unused var. * doc/misc/tramp.texi (Remote programs): * etc/MACHINES, etc/PROBLEMS: Modernize PATH for Oracle Developer Studio. * etc/PROBLEMS: Move Solaris-related problems to legacy area, except those that are still relevant.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac76
1 files changed, 25 insertions, 51 deletions
diff --git a/configure.ac b/configure.ac
index 4ee4517e11c..c9aa076eb3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -748,44 +748,21 @@ case "${canonical}" in
opsys=aix4-2
;;
- ## Suns
- *-sun-solaris* \
- | i[3456]86-*-solaris2* | i[3456]86-*-sunos5* \
- | x86_64-*-solaris2* | x86_64-*-sunos5*)
+ ## Solaris
+ *-*-solaris* | *-*-sunos*)
case "${canonical}" in
i[3456]86-*-* ) ;;
amd64-*-*|x86_64-*-*) ;;
sparc* ) ;;
* ) unported=yes ;;
esac
- case "${canonical}" in
- *-sunos5.[1-9][0-9]* | *-solaris2.[1-9][0-9]* )
- opsys=sol2-10
- emacs_check_sunpro_c=yes
- ;;
- *-sunos5.[1-5]* | *-solaris2.[1-5]* ) unported=yes ;;
- ## Note that Emacs 23.1's NEWS said the following would be dropped.
- *-sunos5.6* | *-solaris2.6* )
- opsys=sol2-6
- RANLIB="ar -ts"
- ;;
- ## 5.7 EOL Aug 2008, 5.8 EOL Mar 2012.
- *-sunos5.[7-9]* | *-solaris2.[7-9]* )
- opsys=sol2-6
- emacs_check_sunpro_c=yes
- ;;
- esac
+ opsys=solaris
## Watch out for a compiler that we know will not work.
- case "${canonical}" in
- *-solaris* | *-sunos5* )
- if [ "x$CC" = x/usr/ucb/cc ]; then
- ## /usr/ucb/cc doesn't work;
- ## we should find some other compiler that does work.
- unset CC
- fi
- ;;
- *) ;;
- esac
+ if [ "$CC" = /usr/ucb/cc ]; then
+ ## /usr/ucb/cc doesn't work;
+ ## we should find some other compiler that does work.
+ unset CC
+ fi
;;
## QNX Neutrino
@@ -1476,14 +1453,11 @@ case "$opsys" in
mingw32)
UNEXEC_OBJ=unexw32.o
;;
- sol2-10)
+ solaris)
# Use the Solaris dldump() function, called from unexsol.c, to dump
# emacs, instead of the generic ELF dump code found in unexelf.c.
# The resulting binary has a complete symbol table, and is better
# for debugging and other observability tools (debuggers, pstack, etc).
- #
- # It is likely that dldump() works with older Solaris too, but this has
- # not been tested, so for now this change is for Solaris 10 or newer.
UNEXEC_OBJ=unexsol.o
;;
*)
@@ -1586,7 +1560,7 @@ case "$opsys" in
qnxnto) LIBS_SYSTEM="-lsocket" ;;
- sol2*) LIBS_SYSTEM="-lsocket -lnsl" ;;
+ solaris) LIBS_SYSTEM="-lsocket -lnsl" ;;
## Motif needs -lgen.
unixware) LIBS_SYSTEM="-lsocket -lnsl -lelf -lgen" ;;
@@ -1647,7 +1621,7 @@ case $opsys in
SYSTEM_TYPE=berkeley-unix
;;
- sol2* | unixware )
+ solaris | unixware )
SYSTEM_TYPE=usg-unix-v
;;
@@ -2291,7 +2265,7 @@ system_malloc=yes
test $with_unexec = yes &&
case "$opsys" in
## darwin ld insists on the use of malloc routines in the System framework.
- darwin | mingw32 | nacl | sol2-10) ;;
+ darwin | mingw32 | nacl | solaris) ;;
cygwin | qnxnto | freebsd)
hybrid_malloc=yes
system_malloc= ;;
@@ -2427,7 +2401,7 @@ if test "$ac_cv_header_pthread_h" && test "$opsys" != "mingw32"; then
# need special flags to disable these optimizations. For example, the
# definition of 'errno' in <errno.h>.
case $opsys in
- hpux* | sol*)
+ hpux* | solaris)
AC_DEFINE([_REENTRANT], 1,
[Define to 1 if your system requires this in multithreaded code.]);;
aix4-2)
@@ -2557,7 +2531,7 @@ fail;
## inoue@ainet.or.jp says Solaris has a bug related to X11R6-style
## XIM support.
case "$opsys" in
- sol2-*) : ;;
+ solaris) : ;;
*) AC_DEFINE(HAVE_X11R6_XIM, 1,
[Define if you have usable X11R6-style XIM support.])
;;
@@ -4692,7 +4666,7 @@ if test "$USE_X_TOOLKIT" != "none"; then
fi
case $opsys in
- sol2* | unixware )
+ solaris | unixware )
dnl Some SVr4s don't define NSIG in sys/signal.h for ANSI environments;
dnl instead, there's a system variable _sys_nsig. Unfortunately, we
dnl need the constant to dimension an array. So wire in the appropriate
@@ -4705,7 +4679,7 @@ emacs_broken_SIGIO=no
case $opsys in
dnl SIGIO exists, but the feature doesn't work in the way Emacs needs.
- hpux* | nacl | openbsd | sol2* | unixware )
+ hpux* | nacl | openbsd | solaris | unixware )
emacs_broken_SIGIO=yes
;;
@@ -4754,7 +4728,7 @@ case $opsys in
esac
case $opsys in
- gnu-* | sol2-10 )
+ gnu-* | solaris )
dnl FIXME Can't we test if this exists (eg /proc/$$)?
AC_DEFINE(HAVE_PROCFS, 1, [Define if you have the /proc filesystem.])
;;
@@ -4883,7 +4857,7 @@ case $opsys in
AC_DEFINE(PTY_TTY_NAME_SPRINTF, [sprintf (pty_name, "/dev/pty/tty%c%x", c, i);])
;;
- sol2* )
+ solaris )
dnl On SysVr4, grantpt(3) forks a subprocess, so do not use
dnl O_CLOEXEC when opening the pty, and keep the SIGCHLD handler
dnl from intercepting that death. If any child but grantpt's should die
@@ -4893,7 +4867,7 @@ case $opsys in
;;
unixware )
- dnl Comments are as per sol2*.
+ dnl Comments are as per solaris.
AC_DEFINE(PTY_OPEN, [fd = open (pty_name, O_RDWR | O_NONBLOCK)])
AC_DEFINE(PTY_TTY_NAME_SPRINTF, [{ char *ptsname (int), *ptyname; int grantpt_result; sigset_t blocked; sigemptyset (&blocked); sigaddset (&blocked, SIGCHLD); pthread_sigmask (SIG_BLOCK, &blocked, 0); grantpt_result = grantpt (fd); pthread_sigmask (SIG_UNBLOCK, &blocked, 0); if (grantpt_result == -1) fatal("could not grant slave pty"); if (unlockpt(fd) == -1) fatal("could not unlock slave pty"); if (!(ptyname = ptsname(fd))) fatal ("could not enable slave pty"); snprintf (pty_name, PTY_NAME_SIZE, "%s", ptyname); }])
;;
@@ -4901,7 +4875,7 @@ esac
case $opsys in
- sol2* | unixware )
+ solaris | unixware )
dnl This change means that we don't loop through allocate_pty too
dnl many times in the (rare) event of a failure.
AC_DEFINE(FIRST_PTY_LETTER, ['z'])
@@ -4996,7 +4970,7 @@ if test x$GCC = xyes; then
AC_DEFINE(GC_SETJMP_WORKS, 1)
else
case $opsys in
- aix* | dragonfly | freebsd | netbsd | openbsd | sol2* )
+ aix* | dragonfly | freebsd | netbsd | openbsd | solaris )
AC_DEFINE(GC_SETJMP_WORKS, 1)
;;
esac
@@ -5043,7 +5017,7 @@ case $emacs_cv_func_sigsetjmp,$emacs_cv_alternate_stack,$opsys in
esac
case $opsys in
- sol2* | unixware )
+ solaris | unixware )
dnl TIOCGPGRP is broken in SysVr4, so we can't send signals to PTY
dnl subprocesses the usual way. But TIOCSIGNAL does work for PTYs,
dnl and this is all we need.
@@ -5053,7 +5027,7 @@ esac
case $opsys in
- hpux* | sol2* )
+ hpux* | solaris )
dnl Used in xfaces.c.
AC_DEFINE(XOS_NEEDS_TIME_H, 1, [Compensate for a bug in Xos.h on
some systems, where it requires time.h.])
@@ -5108,7 +5082,7 @@ case $opsys in
fi
;;
- sol2*)
+ solaris)
AC_DEFINE(USG, [])
AC_DEFINE(USG5_4, [])
AC_DEFINE(SOLARIS2, [], [Define if the system is Solaris.])
@@ -5173,7 +5147,7 @@ case $opsys in
reopen it in the child.])
;;
- sol2-10)
+ solaris)
AC_DEFINE(_STRUCTURED_PROC, 1, [Needed for system_process_attributes
on Solaris.])
;;