summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2020-04-04 16:56:57 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2020-04-04 16:57:43 -0700
commit15853707c8c36aff1d3cc19205971b88e04d007b (patch)
tree500707c66fb48e90d4a10fbfc4a30efef77a91be /configure.ac
parentf71afd600aef77d3c7248ae0e94b8c55fb2c5eb2 (diff)
downloademacs-15853707c8c36aff1d3cc19205971b88e04d007b.tar.gz
Default gcc -Og to inlining key ops
Problem reported by Martin Rudalics in: https://lists.gnu.org/r/emacs-devel/2020-04/msg00195.html * configure.ac (DEFINE_KEY_OPS_AS_MACROS): Define if -Og. * src/Makefile.in (KEY_OPS_CFLAGS): New macro. (EMACS_CFLAGS): Use it. * src/lisp.h (DEFINE_KEY_OPS_AS_MACROS): Let the gcc command line specify it. Remove use of undocumented INLINING macro.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9907160482e..4e34a1cc10c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -938,6 +938,13 @@ if test "$ac_test_CFLAGS" != set; then
esac
fi
+case "$GCC, $CFLAGS " in
+ yes,*' -Og '*)
+ AC_DEFINE([DEFINE_KEY_OPS_AS_MACROS], 1,
+ [Define to 1 if key low-level operations should be C macros
+ instead of inline functions.])
+esac
+
# gl_GCC_VERSION_IFELSE([major], [minor], [run-if-found], [run-if-not-found])
# ---------------------------------------------------------------------------
# If $CPP is gcc-MAJOR.MINOR or newer, then run RUN-IF-FOUND.