summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorleo <gnu_lists@halloleo.hailmail.net>2020-08-26 15:03:08 +0200
committerLars Ingebrigtsen <larsi@gnus.org>2020-08-26 15:03:08 +0200
commit3345dc8e15bbbb96fa07b402106a7ca1f4da9559 (patch)
treeb63d84ce8204e863289e7cb0ac8ecffc69e60471 /configure.ac
parentfca0d6e875e7eb3ab3ca117e7552315e1a56b282 (diff)
downloademacs-3345dc8e15bbbb96fa07b402106a7ca1f4da9559.tar.gz
Allow disabling double buffering at build time
* configure.ac: Allow disabling double buffering (bug#32032). Copyright-paperwork-exempt: yes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index fb9aa19d6ee..9a51ea1f7ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -463,6 +463,7 @@ OPTION_DEFAULT_ON([m17n-flt],[don't use m17n-flt for text shaping])
OPTION_DEFAULT_ON([toolkit-scroll-bars],[don't use Motif/Xaw3d/GTK toolkit scroll bars])
OPTION_DEFAULT_ON([xaw3d],[don't use Xaw3d])
OPTION_DEFAULT_ON([xim],[at runtime, default X11 XIM to off])
+OPTION_DEFAULT_ON([xdbe],[don't use X11 double buffering support])
AC_ARG_WITH([ns],[AS_HELP_STRING([--with-ns],
[use Nextstep (macOS Cocoa or GNUstep) windowing system.
On by default on macOS.])],[],[with_ns=maybe])
@@ -4023,11 +4024,13 @@ AC_SUBST(XFIXES_LIBS)
### Use Xdbe (-lXdbe) if available
HAVE_XDBE=no
if test "${HAVE_X11}" = "yes"; then
- AC_CHECK_HEADER(X11/extensions/Xdbe.h,
- [AC_CHECK_LIB(Xext, XdbeAllocateBackBufferName, HAVE_XDBE=yes)],
- [],
- [#include <X11/Xlib.h>
- ])
+ if test "${with_xdbe}" != "no"; then
+ AC_CHECK_HEADER(X11/extensions/Xdbe.h,
+ [AC_CHECK_LIB(Xext, XdbeAllocateBackBufferName, HAVE_XDBE=yes)],
+ [],
+ [#include <X11/Xlib.h>
+ ])
+ fi
if test $HAVE_XDBE = yes; then
XDBE_LIBS=-lXext
fi