summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Pluim <rpluim@gmail.com>2020-11-12 16:51:49 +0100
committerRobert Pluim <rpluim@gmail.com>2020-11-12 16:52:23 +0100
commit56a7c73f9ce3b92251c332691de273ccd9894632 (patch)
treed1918cea23fba61ca250a13cb761c5513cea8976 /configure.ac
parenta5b48e25fe966ed67f314b77903335e8238ce8f9 (diff)
downloademacs-56a7c73f9ce3b92251c332691de273ccd9894632.tar.gz
Emit required version when Harfbuzz is not found but Cairo is
* configure.ac: Define harfbuzz_required_ver with required harfbuzz version, and put it in the warning message emitted when Cairo is found but not HarfBuzz.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 11 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index f0c8e5210f9..888b4151487 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3444,16 +3444,17 @@ else # "${HAVE_X11}" != "yes"
fi # "${HAVE_X11}" != "yes"
HAVE_HARFBUZZ=no
+### On MS-Windows we use hb_font_get_nominal_glyph, which appeared
+### in HarfBuzz version 1.2.3
+if test "${HAVE_W32}" = "yes"; then
+ harfbuzz_required_ver=1.2.3
+else
+ harfbuzz_required_ver=0.9.42
+fi
if test "${HAVE_X11}" = "yes" && test "${HAVE_FREETYPE}" = "yes" \
|| test "${HAVE_W32}" = "yes"; then
if test "${with_harfbuzz}" != "no"; then
- ### On MS-Windows we use hb_font_get_nominal_glyph, which appeared
- ### in HarfBuzz version 1.2.3
- if test "${HAVE_W32}" = "yes"; then
- EMACS_CHECK_MODULES([HARFBUZZ], [harfbuzz >= 1.2.3])
- else
- EMACS_CHECK_MODULES([HARFBUZZ], [harfbuzz >= 0.9.42])
- fi
+ EMACS_CHECK_MODULES([HARFBUZZ], [harfbuzz >= $harfbuzz_required_ver])
if test "$HAVE_HARFBUZZ" = "yes"; then
AC_DEFINE(HAVE_HARFBUZZ, 1, [Define to 1 if using HarfBuzz.])
### mingw32 and Cygwin-w32 don't use -lharfbuzz, since they load
@@ -5918,9 +5919,9 @@ fi
if test "${HAVE_CAIRO}" = "yes" && test "${HAVE_HARFBUZZ}" = no; then
AC_MSG_WARN([This configuration uses the Cairo graphics library,
- but not the HarfBuzz font shaping library. We recommend the use
- of HarfBuzz when using Cairo, please install HarfBuzz development
- packages.])
+ but not the HarfBuzz font shaping library (minimum version $harfbuzz_required_ver).
+ We recommend the use of HarfBuzz when using Cairo, please install
+ appropriate HarfBuzz development packages.])
fi
# Let plain 'make' work.