summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2020-12-25 19:16:27 -0800
committerPaul Eggert <eggert@cs.ucla.edu>2020-12-25 19:17:04 -0800
commit60bfa84e41449020d1122a1d18b7c11cb73211f3 (patch)
tree22e2a3fc2df1a819aeb66b9beafade3a5cb9f996 /configure.ac
parenta63855cd21aefee993b622241993043a31894c0c (diff)
downloademacs-60bfa84e41449020d1122a1d18b7c11cb73211f3.tar.gz
Fix issues with lib/malloc out-of-dir builds
Problem reported by Mattias EngdegÄrd in: https://lists.gnu.org/r/emacs-devel/2020-12/msg01626.html * configure.ac: If the scratch_buffer module is enabled, create lib/malloc and (if doing dependencies) lib/deps/malloc. * lib/Makefile.in (DEPFLAGS) [AUTO_DEPEND]: No longer any need to squash lib dependencies into a single directory. (clean): Also remove */*.o and $(DEPDIR)/*/*.d, to clean out malloc/*.o and deps/malloc/*.d. Just remove *.d files in dependencies so that rm does not complain about not being able to remove deps/malloc. (extraclean): Also remove malloc, if it is empty.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 888b4151487..bf768441fe3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5878,6 +5878,12 @@ if test $AUTO_DEPEND = yes; then
AS_MKDIR_P([$dir/deps])
done
fi
+if $gl_gnulib_enabled_scratch_buffer; then
+ AS_MKDIR_P([lib/malloc])
+ if test $AUTO_DEPEND = yes; then
+ AS_MKDIR_P([lib/deps/malloc])
+ fi
+fi
AC_OUTPUT