summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Pluim <rpluim@gmail.com>2021-01-11 13:11:51 +0100
committerRobert Pluim <rpluim@gmail.com>2021-01-11 13:11:51 +0100
commit62e3750af306218a6dc08b1a2ca62e9a73aa306f (patch)
tree154e27850e62e9c13b8807d6ce28aa65adec10dc /configure.ac
parent17bd039539d22a0a2da792d3921f2c603cc2d460 (diff)
downloademacs-62e3750af306218a6dc08b1a2ca62e9a73aa306f.tar.gz
Ensure HAVE_GMP is reflected in emacs_config_features
* configure.ac: Move HAVE_GMP setting before emacs_config_features setting (Bug#45771).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 66c660696b7..616fa55b8aa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5657,6 +5657,12 @@ else
ACL_SUMMARY=no
fi
+if test -z "$GMP_H"; then
+ HAVE_GMP=yes
+else
+ HAVE_GMP=no
+fi
+
emacs_standard_dirs='Standard dirs'
AS_ECHO(["
Configured for '${canonical}'.
@@ -5713,11 +5719,6 @@ done
AC_DEFINE_UNQUOTED(EMACS_CONFIG_FEATURES, "${emacs_config_features}",
[Summary of some of the main features enabled by configure.])
-if test -z "$GMP_H"; then
- HAVE_GMP=yes
-else
- HAVE_GMP=no
-fi
AS_ECHO([" Does Emacs use -lXaw3d? ${HAVE_XAW3D}
Does Emacs use -lXpm? ${HAVE_XPM}
Does Emacs use -ljpeg? ${HAVE_JPEG}