summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2020-05-27 09:45:49 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2020-05-27 09:51:12 -0700
commit9d11f127f15cc4dafcdb825dcfc6e495d729a069 (patch)
tree86ef1c845ace94bb75e689771906e54d274114c3 /configure.ac
parent22446569cd319403e6e5e19369439ec71c46150d (diff)
downloademacs-9d11f127f15cc4dafcdb825dcfc6e495d729a069.tar.gz
--with-wide-int is a no-op on 64-bit hosts
* configure.ac: Clarify wording for --with-wide-int help. * src/pdumper.c (dump_vectorlike_generic): Do the eassert even if --with-wide-int was specified unnecessarily.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 719eb747ae1..b1b8c846e14 100644
--- a/configure.ac
+++ b/configure.ac
@@ -414,7 +414,11 @@ this option's value should be 'yes', 'no', 'lucid', 'athena', 'motif', 'gtk',
with_x_toolkit=$val
])
-OPTION_DEFAULT_OFF([wide-int], [prefer wide Emacs integers (typically 62-bit); allows buffer and string size up to 2GB on 32-bit hosts, at the cost of 10% to 30% slowdown of Lisp interpreter and larger memory footprint])
+OPTION_DEFAULT_OFF([wide-int],
+ [prefer wide Emacs integers (typically 62-bit);
+ on 32-bit hosts, this allows buffer and string size up to 2GB,
+ at the cost of 10% to 30% slowdown of Lisp interpreter
+ and larger memory footprint])
if test "$with_wide_int" = yes; then
AC_DEFINE([WIDE_EMACS_INT], 1, [Use long long for EMACS_INT if available.])
fi