summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2012-09-14 15:01:19 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2012-09-14 15:01:19 -0700
commit2af0342954599918f739d981e8151f7e8a46c3c6 (patch)
tree4eadf341a552603165d813608ae8765e794a1fd8 /configure.ac
parente3141fcf8456dc1ec7455e34437ac09f0c812ac9 (diff)
downloademacs-2af0342954599918f739d981e8151f7e8a46c3c6.tar.gz
Fix glitches with 'configure --without-sync-input'.
* configure.ac (--without-sync-input): Fix typo in usage message. * alloc.c [!SYSTEM_MALLOC && !SYNC_INPUT && HAVE_PTHREAD]: Include "syssignal.h", for 'main_thread'.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index accbb68e7b0..382e62a97a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -128,7 +128,7 @@ AC_ARG_WITH([mailhost],[AS_HELP_STRING([--with-mailhost=HOSTNAME],
OPTION_DEFAULT_ON([sound],[don't compile with sound support])
-OPTION_DEFAULT_ON([sync-input],[process async input synchronously])
+OPTION_DEFAULT_ON([sync-input],[don't process async input synchronously])
if test "$with_sync_input" = yes; then
AC_DEFINE(SYNC_INPUT, 1, [Process async input synchronously.])
fi