summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2012-09-03 12:34:49 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2012-09-03 12:34:49 -0700
commit79a7bafe62de094b745a47c2b90b17ada5fc5a21 (patch)
tree996d0da26b9c13850704da6fe9a3d4fe4078c2a4 /configure.ac
parentdcde497f27945c3ca4ce8c21f655ef6f627acdd2 (diff)
downloademacs-79a7bafe62de094b745a47c2b90b17ada5fc5a21.tar.gz
* configure.ac (WARN_CFLAGS): Omit -Wjump-misses-init.
It generates false alarms in doc.c, regex.c, xdisp.c. See <http://lists.gnu.org/archive/html/emacs-devel/2012-09/msg00040.html>.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0e2154aab6e..77e11910553 100644
--- a/configure.ac
+++ b/configure.ac
@@ -705,6 +705,7 @@ else
nw="$nw -Wswitch-default" # Too many warnings for now
nw="$nw -Wfloat-equal" # warns about high-quality code
nw="$nw -Winline" # OK to ignore 'inline'
+ nw="$nw -Wjump-misses-init" # We sometimes safely jump over init.
nw="$nw -Wsync-nand" # irrelevant here, and provokes ObjC warning
nw="$nw -Wunsafe-loop-optimizations" # OK to suppress unsafe optimizations