summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2013-12-27 16:40:58 -0800
committerPaul Eggert <eggert@cs.ucla.edu>2013-12-27 16:40:58 -0800
commit1d7701a4fdb6272c6a64caad6f41c9e41b9a7916 (patch)
tree320b90ffe88404c87a2fc7d7d8f8160f9bb75244 /configure.ac
parente9dc713d18e425597339d6e2ed4a5fb2924d205d (diff)
downloademacs-1d7701a4fdb6272c6a64caad6f41c9e41b9a7916.tar.gz
Fix problem with MAKE and xcrun configuration.
* configure.ac: Don't set MAKE unless 'make' doesn't work. Set it only in the environment, not in the makefile. Problem reported by Glenn Morris in: http://lists.gnu.org/archive/html/emacs-devel/2013-12/msg00969.html
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f0659457a79..6c08c7c7308 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,8 +85,15 @@ AC_CONFIG_AUX_DIR(build-aux)
xcsdkdir=
AC_CHECK_PROGS(XCRUN, [xcrun])
if test -n "$XCRUN"; then
- AC_CHECK_PROGS(MAKE, [make "$XCRUN make"])
- test -n "$MAKE" && export MAKE
+ if test -z "$MAKE"; then
+ dnl Call the variable MAKE_PROG, not MAKE, to avoid confusion with
+ dnl SET_MAKE and with the usual MAKE variable that 'make' itself uses.
+ AC_CHECK_PROG([MAKE_PROG], [make], [yes])
+ if test -z "$MAKE_PROG"; then
+ MAKE="$XCRUN MAKE"
+ export MAKE
+ fi
+ fi
xcsdkdir=`$XCRUN --show-sdk-path 2>/dev/null`
fi