summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2013-12-11 14:31:02 -0800
committerPaul Eggert <eggert@cs.ucla.edu>2013-12-11 14:31:02 -0800
commit7204a2e666b34d8b309b7b8568c88032468e207e (patch)
tree40eefecf7cac67fe1d61887986f651c72604e4cc /configure.ac
parent7b3f56792cb7d093aacc14dda81960dd75c23c4d (diff)
downloademacs-7204a2e666b34d8b309b7b8568c88032468e207e.tar.gz
Make 'configure' work out-of-the-box on Solaris.
* configure.ac: Work even if libgif etc. are missing. Emacs works without these libraries even if its default GUI is harmed, so they are not strictly necessary. Another possibility would be to disable X11 if these libraries are missing. The point is that a plain 'configure' should not fail on platforms like Solaris 11 where one or more image libraries are not installed by default.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 41258fcb7a9..0720b4bf56e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3106,7 +3106,8 @@ elif test "${HAVE_X11}" = "yes" && test "${with_gif}" != "no" \
fi
AC_SUBST(LIBGIF)
-dnl Check for required libraries.
+dnl If using X11, warn if image libraries are missing.
+dnl It's not fatal if they're absent, though the UI may suffer.
if test "${HAVE_X11}" = "yes"; then
MISSING=""
WITH_NO=""
@@ -3122,12 +3123,12 @@ if test "${HAVE_X11}" = "yes"; then
MISSING="$MISSING libtiff" && WITH_NO="$WITH_NO --with-tiff=no"
if test "X${MISSING}" != X; then
- AC_MSG_ERROR([The following required libraries were not found:
+ AC_MSG_WARN([X11 used, but the following libraries were not found:
$MISSING
Maybe some development libraries/packages are missing?
-If you don't want to link with them give
+Emacs will be built without them. To silence this warning, give
$WITH_NO
-as options to configure])
+as options to 'configure'.])
fi
fi