summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2014-05-30 13:19:29 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2014-05-30 13:19:29 -0700
commit1915d8d63cb4de3b7fcadf059f1fe7f20fc5f8bf (patch)
treeb91c84b78c5610a2f218b00036843cf9f52a6248 /configure.ac
parentff66db795045b919717b16288ac083f6eafbdcb0 (diff)
downloademacs-1915d8d63cb4de3b7fcadf059f1fe7f20fc5f8bf.tar.gz
Fix port to 32-bit AIX with xlc.
This doesn't fix Bug#17598, but it does fix a regression since Emacs built with xlc until recently, and perhaps it'll help us fix Bug#17598. * configure.ac (GC_SETJMP_WORKS): Define for AIX, too. Merge from gnulib, incorporating: 2014-05-30 ftoastr: work around compiler bug in IBM xlc 12.1 * lib/ftoastr.c: Update from gnulib. * src/alloc.c (gdb_make_enums_visible): Remove FLOAT_TO_STRING_BUFSIZE. * src/conf_post.h (FLEXIBLE_ARRAY_MEMBER) [__IBMC__]: Don't define to empty. * src/lisp.h (FLOAT_TO_STRING_BUFSIZE): Make it a macro, instead of an enum, to work around a compiler bug in IBM xlc 12.1.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0f4351fcd5d..3de3cb97c04 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4380,7 +4380,7 @@ if test x$GCC = xyes; then
else
case $opsys in
dnl irix: Tested on Irix 6.5. SCM worked on earlier versions.
- dragonfly | freebsd | netbsd | openbsd | irix6-5 | sol2* )
+ aix* | dragonfly | freebsd | netbsd | openbsd | irix6-5 | sol2* )
AC_DEFINE(GC_SETJMP_WORKS, 1)
;;
esac