summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2014-06-06 23:10:39 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2014-06-06 23:10:39 -0700
commita0e26ff003c14925278c5bf5939615a4ccd0ac29 (patch)
tree2c5aa468d5891e8b3d23b24b963c4708301cedd2 /configure.ac
parent7f11800984ed1805caaba36cd67d5dcc7c394d1d (diff)
downloademacs-a0e26ff003c14925278c5bf5939615a4ccd0ac29.tar.gz
Port better to AIX.
* configure.ac (with_xpm_set): New shell var. (_THREAD_SAFE): Define on AIX if HAVE_PTHREAD. (with_xpm): Default to 'no' on AIX. (LIBXPM): Append -lXpm if -lXaw is also used, as the latter requires the former on AIX. Fixes: debbugs:17598
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3de3cb97c04..600271d1119 100644
--- a/configure.ac
+++ b/configure.ac
@@ -242,6 +242,7 @@ fi
dnl _ON results in a '--without' option in the --help output, so
dnl the help text should refer to "don't compile", etc.
+with_xpm_set=${with_xpm+set}
OPTION_DEFAULT_ON([xpm],[don't compile with XPM image support])
OPTION_DEFAULT_ON([jpeg],[don't compile with JPEG image support])
OPTION_DEFAULT_ON([tiff],[don't compile with TIFF image support])
@@ -2074,6 +2075,14 @@ if test "$HAVE_PTHREAD" = yes; then
LIBS="$LIB_PTHREAD $LIBS" ;;
esac
AC_DEFINE(HAVE_PTHREAD, 1, [Define to 1 if you have pthread (-lpthread).])
+
+ # Some systems optimize for single-threaded programs by default, and
+ # need special flags to disable these optimizations. For example, the
+ # definition of 'errno' in <errno.h>.
+ if test "$opsys" = aix4-2; then
+ AC_DEFINE([_THREAD_SAFE], [1],
+ [Define to 1 if your system requires this in multithreaded code.])
+ fi
fi
AC_SUBST([LIB_PTHREAD])
@@ -2984,6 +2993,9 @@ no_return_alloc_pixels
fi
if test "${HAVE_X11}" = "yes"; then
+ dnl Avoid Xpm on AIX unless requested, as it crashes; see Bug#17598.
+ test "$opsys$with_xpm_set" = aix4-2 && with_xpm=no
+
if test "${with_xpm}" != "no"; then
AC_CHECK_HEADER(X11/xpm.h,
[AC_CHECK_LIB(Xpm, XpmReadFileToPixmap, HAVE_XPM=yes, , -lX11)])
@@ -3007,6 +3019,9 @@ no_return_alloc_pixels
if test "${HAVE_XPM}" = "yes"; then
AC_DEFINE(HAVE_XPM, 1, [Define to 1 if you have the Xpm library (-lXpm).])
LIBXPM=-lXpm
+ elif test "$opsys,$LUCID_LIBW" = aix4-2,-lXaw; then
+ dnl AIX -lXaw needs -lXpm linked too; see Bug#17598 Message#152.
+ LIBXPM=-lXpm
fi
fi