summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Djärv <jan.h.d@swipnet.se>2014-03-31 08:08:29 +0200
committerJan Djärv <jan.h.d@swipnet.se>2014-03-31 08:08:29 +0200
commitdcb4c4d7532840328bf7b42909f80f662264d007 (patch)
tree14172364b232e2fd358b67e00ea923ee5a74587a /configure.ac
parent8e86e380dc76be2e49f23c9bf7f28eda076875c7 (diff)
downloademacs-dcb4c4d7532840328bf7b42909f80f662264d007.tar.gz
* configure.ac: Fix errors from previous checkin (GSettings check).
Backport from trunk.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 971674bb3f2..9074cb2ffe6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2432,6 +2432,10 @@ HAVE_GSETTINGS=no
if test "${HAVE_X11}" = "yes" && test "${with_gsettings}" = "yes"; then
PKG_CHECK_MODULES(GSETTINGS, gio-2.0 >= 2.26, HAVE_GSETTINGS=yes, HAVE_GSETTINGS=no)
if test "$HAVE_GSETTINGS" = "yes"; then
+ old_CFLAGS=$CFLAGS
+ CFLAGS="$CFLAGS $GSETTINGS_CFLAGS"
+ old_LIBS=$LIBS
+ LIBS="$LIBS $GSETTINGS_LIBS"
AC_MSG_CHECKING([whether GSettings is in gio])
GSETTINGS_COMPILES=no
AC_LINK_IFELSE(
@@ -2447,11 +2451,13 @@ if test "${HAVE_X11}" = "yes" && test "${with_gsettings}" = "yes"; then
[GSETTINGS_COMPILES=yes])
AC_MSG_RESULT([$GSETTINGS_COMPILES])
- if test "$$GSETTINGS_COMPILES" = "yes"; then
+ if test "$GSETTINGS_COMPILES" = "yes"; then
AC_DEFINE(HAVE_GSETTINGS, 1, [Define to 1 if using GSettings.])
SETTINGS_CFLAGS="$GSETTINGS_CFLAGS"
SETTINGS_LIBS="$GSETTINGS_LIBS"
fi
+ CFLAGS=$old_CFLAGS
+ LIBS=$old_LIBS
fi
fi