summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKen Brown <kbrown@cornell.edu>2014-04-09 17:16:37 -0400
committerKen Brown <kbrown@cornell.edu>2014-04-09 17:16:37 -0400
commit0cccc183d7530d342e7970f4544cdf70e3327cb6 (patch)
tree53838100f6169119fb7d3c7edcea5826f9a1e6c5 /configure.ac
parent50c9a9b8a871ce281b43a196bd912f3d2fdda5fa (diff)
downloademacs-0cccc183d7530d342e7970f4544cdf70e3327cb6.tar.gz
Revert most of the recent change involving manifests on Cygwin. (Bug#17176)
* configure.ac (EMACS_MANIFEST): Revert last change (but leave UPDATE_MANIFEST empty). * nt/emacs.rc: Revert last change. * src/Makefile.in (EMACS_MANIFEST): Revert last change.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 086bd7d4bdf..f7675fb4056 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1834,6 +1834,10 @@ if test "${HAVE_W32}" = "yes"; then
W32_OBJ="w32fns.o w32menu.o w32reg.o w32font.o w32term.o"
W32_OBJ="$W32_OBJ w32xfns.o w32select.o w32uniscribe.o"
EMACSRES="emacs.res"
+ case "$canonical" in
+ x86_64-*-*) EMACS_MANIFEST="emacs-x64.manifest" ;;
+ *) EMACS_MANIFEST="emacs-x86.manifest" ;;
+ esac
if test "${opsys}" = "cygwin"; then
W32_LIBS="$W32_LIBS -lkernel32 -luser32 -lgdi32 -lole32 -lcomdlg32"
W32_LIBS="$W32_LIBS -lusp10 -lcomctl32 -lwinspool"
@@ -1841,10 +1845,6 @@ if test "${HAVE_W32}" = "yes"; then
# the rc file), not a linker script.
W32_RES_LINK="-Wl,emacs.res"
else
- case "$canonical" in
- x86_64-*-*) EMACS_MANIFEST="emacs-x64.manifest" ;;
- *) EMACS_MANIFEST="emacs-x86.manifest" ;;
- esac
UPDATE_MANIFEST=update-game-score.exe.manifest
W32_OBJ="$W32_OBJ w32.o w32console.o w32heap.o w32inevt.o w32proc.o"
W32_LIBS="$W32_LIBS -lwinmm -lgdi32 -lcomdlg32"