summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2014-06-20 12:46:18 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2014-06-20 12:46:18 -0700
commit81e5c6fc89e277237cf290927fe339b53ad47b80 (patch)
treea0c33cae86d8b1b3a5d9da2fe958fda191c0f13e /configure.ac
parentf49b49787c954ae858007ad149552a8af5b9d1e0 (diff)
downloademacs-81e5c6fc89e277237cf290927fe339b53ad47b80.tar.gz
* configure.ac: Warn about --enable-link-time-optimization's issues
in --help message. Fixes: debbugs:17806
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e9400047edc..3d840a1b484 100644
--- a/configure.ac
+++ b/configure.ac
@@ -757,7 +757,10 @@ AC_ARG_ENABLE([gcc-warnings],
AC_ARG_ENABLE(link-time-optimization,
[AS_HELP_STRING([--enable-link-time-optimization],
[build emacs with link-time optimization.
- This is supported only for GCC since 4.5.0.])],
+ This requires GCC 4.5.0 or later.
+ It also makes Emacs harder to debug, and when we tried it
+ with GCC 4.9.0 x86-64 it made Emacs slower, so it's not
+ recommended for typical use.])],
if test "${enableval}" != "no"; then
AC_MSG_CHECKING([whether link-time optimization is supported])
ac_lto_supported=no