summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2015-11-17 21:07:37 +0200
committerEli Zaretskii <eliz@gnu.org>2015-11-17 21:07:37 +0200
commitabf673af29ba2a2e0001ebd1db183377724f0cc4 (patch)
treef8cc95488858c5e856c325ece5cab2db89ad7359 /configure.ac
parentce4eeca8d40edf95eeca05c76f4b474d38ea8d6d (diff)
downloademacs-abf673af29ba2a2e0001ebd1db183377724f0cc4.tar.gz
Improve configure --help text for wide ints
* configure.ac (wide-int): Clarify user-level advantages and disadvantages.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 94ee9b7aa2b..cfd591c7b86 100644
--- a/configure.ac
+++ b/configure.ac
@@ -316,7 +316,7 @@ this option's value should be 'yes', 'no', 'lucid', 'athena', 'motif', 'gtk',
with_x_toolkit=$val
])
-OPTION_DEFAULT_OFF([wide-int], [prefer wide Emacs integers (typically 62-bit)])
+OPTION_DEFAULT_OFF([wide-int], [prefer wide Emacs integers (typically 62-bit); allows buffer and string size up to 2GB on 32-bit hosts, at the cost of 10% to 30% slowdown of Lisp interpreter and larger memory footprint])
if test "$with_wide_int" = yes; then
AC_DEFINE([WIDE_EMACS_INT], 1, [Use long long for EMACS_INT if available.])
fi