summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2016-04-15 19:19:47 -0400
committerGlenn Morris <rgm@gnu.org>2016-04-15 19:19:47 -0400
commitf3653ec446ed95404889cf16c67b2d96b3955f52 (patch)
tree22369e7d04e84d1032cff3fcfa2df5f274fe9fcd /configure.ac
parentab849b7fac5f7a4bb301eb830fa0acc3ad18c18f (diff)
downloademacs-f3653ec446ed95404889cf16c67b2d96b3955f52.tar.gz
* configure.ac (HAVE_MODULES): Treat gnu like gnu-linux. (Bug#22722)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 20 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index d31b8df2b04..d803363a279 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3336,24 +3336,26 @@ HAVE_MODULES=no
MODULES_OBJ=
MODULES_SUFFIX=
if test "${with_modules}" != "no"; then
- if test "$opsys" = "gnu-linux"; then
- LIBMODULES="-ldl"
- MODULES_SUFFIX=".so"
- HAVE_MODULES=yes
- elif test "$opsys" = "cygwin"; then
- MODULES_SUFFIX=".dll"
- HAVE_MODULES=yes
- elif test "$opsys" = "darwin"; then
- MODULES_SUFFIX=".so"
- HAVE_MODULES=yes
- elif test "$opsys" = "mingw32"; then
- MODULES_SUFFIX=".dll"
- HAVE_MODULES=yes
- else
- # BSD system have dlopen in the libc
- AC_CHECK_FUNC(dlopen, [MODULES_SUFFIX=".so"]
- [HAVE_MODULES=yes], [])
- fi
+ case $opsys in
+ gnu*)
+ LIBMODULES="-ldl"
+ MODULES_SUFFIX=".so"
+ HAVE_MODULES=yes
+ ;;
+ cygwin|mingw32)
+ MODULES_SUFFIX=".dll"
+ HAVE_MODULES=yes
+ ;;
+ darwin)
+ MODULES_SUFFIX=".so"
+ HAVE_MODULES=yes
+ ;;
+ *)
+ # BSD system have dlopen in the libc
+ AC_CHECK_FUNC(dlopen, [MODULES_SUFFIX=".so"]
+ [HAVE_MODULES=yes], [])
+ ;;
+ esac
if test "${HAVE_MODULES}" = no; then
AC_MSG_ERROR([Dynamic modules are not supported on your system])