summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNoam Postavsky <npostavs@users.sourceforge.net>2017-10-31 13:31:46 -0400
committerNoam Postavsky <npostavs@gmail.com>2017-11-04 18:49:28 -0400
commit918a2dda07ebf16601a93d0464f62c4e846d8b39 (patch)
treef98b930dcbcfb83608c38d949254dabaeeddaec9 /configure.ac
parent725ab635d9c4c0ecbd4b28df16d2b97337bbe989 (diff)
downloademacs-918a2dda07ebf16601a93d0464f62c4e846d8b39.tar.gz
Use hybrid malloc for FreeBSD (Bug#28308)
FreeBSD aarch64 does not provide sbrk, so gmalloc cannot be used; when using system malloc dumping does not work correctly (allocated data is invalid after dumping). * configure.ac: Set hybrid_malloc for freebsd. * src/gmalloc.c (gdefault_morecore) [!HAVE_SBRK]: Don't call sbrk.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d397e8fa7e1..5579342c4e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2218,7 +2218,7 @@ test "$CANNOT_DUMP" = yes ||
case "$opsys" in
## darwin ld insists on the use of malloc routines in the System framework.
darwin | mingw32 | nacl | sol2-10) ;;
- cygwin | qnxto)
+ cygwin | qnxto | freebsd)
hybrid_malloc=yes
system_malloc= ;;
*) test "$ac_cv_func_sbrk" = yes && system_malloc=$emacs_cv_sanitize_address;;