summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2017-10-03 15:42:10 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2017-10-03 15:46:15 -0700
commitaf2a40fbd37a663a8ee5a722f9fecb80c425c128 (patch)
tree9f331e74730a2a41ac62658e99be418efa62c2e4 /configure.ac
parent4ac5ac50c94b20acdad3746ee168a72d8dd18b4f (diff)
downloademacs-af2a40fbd37a663a8ee5a722f9fecb80c425c128.tar.gz
--with-pop is now the default only on MS-Windows
Problem reported by N. Jackson (Bug#28597). This improves an earlier suggestion by Robert Pluim (Bug#28597#47). * INSTALL, configure.ac, etc/NEWS: Make --with-pop the default only on native MS-Windows.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 13 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index eb2c6840402..3feac73bed3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -232,9 +232,9 @@ AC_DEFUN([OPTION_DEFAULT_ON], [dnl
m4_bpatsubst([with_$1], [[^0-9a-z]], [_])=$with_features])dnl
])dnl
-# FIXME: The default options '--without-mailutils --with-pop' result
-# in a movemail implementation that supports only unencrypted POP3
-# connections. Encrypted connections should be the default.
+# For retrieving mail, unencrypted network connections are the default
+# only on native MS-Windows platforms. (FIXME: These platforms should
+# also be secure by default.)
AC_ARG_WITH([mailutils],
[AS_HELP_STRING([--with-mailutils],
@@ -251,9 +251,16 @@ if test "$with_mailutils" = no; then
fi
AC_SUBST([with_mailutils])
-OPTION_DEFAULT_ON([pop],
- [don't support POP mail retrieval with movemail (--without-pop or
- --with-mailutils is recommended, as movemail POP is insecure)])
+AC_ARG_WITH([pop],
+ [AS_HELP_STRING([--with-pop],
+ [Support POP mail retrieval if Emacs movemail is used (not recommended,
+ as Emacs movemail POP is insecure). This is the default only on
+ native MS-Windows.])],
+ [],
+ [case $host in
+ *-mingw*) with_pop=yes;;
+ *) with_pop=no;;
+ esac])
if test "$with_pop" = yes; then
AC_DEFINE(MAIL_USE_POP)
fi