summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Pluim <rpluim@gmail.com>2019-12-19 17:33:16 +0100
committerRobert Pluim <rpluim@gmail.com>2020-01-06 15:27:26 +0100
commit9063124b9125ed5e2ad87bbb8bd6224526723a92 (patch)
treec21c1134698c8d2a131fd387dc3742645c3a1bd2 /configure.ac
parent088bfcc2d80eed44864147f3491eff69e4eb5cd8 (diff)
downloademacs-9063124b9125ed5e2ad87bbb8bd6224526723a92.tar.gz
Use pthread_setname_np to set thread name
* configure.ac: Remove check for sys/prctl.h and prctl, check for pthread_setname_np instead. * systhread.c: Remove sys/prctl.h include. (sys_thread_create) [HAVE_PTHREAD_SETNAME_NP]: Use pthread_setname_np to set the name of the newly created thread (Bug#38632). * thread.c (Fmake_thread): Use ENCODE_SYSTEM instead of ENCODE_UTF_8 on the thread name.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 39bfcf59886..de4710f150a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1767,7 +1767,7 @@ AC_CHECK_HEADERS_ONCE(
sys/sysinfo.h
coff.h pty.h
sys/resource.h
- sys/utsname.h pwd.h utmp.h util.h sys/prctl.h)
+ sys/utsname.h pwd.h utmp.h util.h)
AC_CACHE_CHECK([for ADDR_NO_RANDOMIZE],
[emacs_cv_personality_addr_no_randomize],
@@ -4180,7 +4180,7 @@ pthread_sigmask strsignal setitimer timer_getoverrun \
sendto recvfrom getsockname getifaddrs freeifaddrs \
gai_strerror sync \
getpwent endpwent getgrent endgrent \
-cfmakeraw cfsetspeed __executable_start log2 prctl)
+cfmakeraw cfsetspeed __executable_start log2 pthread_setname_np)
LIBS=$OLD_LIBS
dnl No need to check for posix_memalign if aligned_alloc works.