summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2019-06-01 12:53:41 +0300
committerEli Zaretskii <eliz@gnu.org>2019-06-01 12:53:41 +0300
commit4363777d5c60af8bc93b30d4f6c5e12dc2761160 (patch)
tree2ff9ea97c469140df5630f6ee5c250e745a78dcb /configure.ac
parentb7730c259bc91f030069e408aaddb43f02da3a3a (diff)
downloademacs-4363777d5c60af8bc93b30d4f6c5e12dc2761160.tar.gz
Move common HarfBuzz code to a common file hbfont.c
* src/hbfont.c: New file, with code moved from w32uniscribe.c and renamed/modified as appropriate. * src/w32uniscribe.c: Move to hbfont.c DEF_DLL_FN and macro definitions for HarfBuzz functions used in hbfont.c (load_harfbuzz_funcs): Move loading of HarfBuzz functions used by hbfont.c to hbfont.c:hbfont_init_w32_funcs, and call that function from here. (syms_of_w32uniscribe_for_pdumper): Fill the 'shape' and 'combining_capability' members with hbfont.c function names. * src/w32common.h (hbfont_init_w32_funcs) [HAVE_HARFBUZZ]: Add prototype. * src/font.h (hbfont_shape, hbfont_combining_capability) [HAVE_HARFBUZZ]: Add prototypes. * src/Makefile.in (SOME_MACHINE_OBJECTS): Add hbfont.o. * configure.ac (FONT_OBJ): Add hbfont.o if HAVE_HARFBUZZ.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ab6b03f5462..b228571c177 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5260,8 +5260,11 @@ if test "${HAVE_X_WINDOWS}" = "yes" ; then
elif test "$HAVE_FREETYPE" = "yes"; then
FONT_OBJ="$FONT_OBJ ftfont.o ftxfont.o"
fi
- AC_SUBST(FONT_OBJ)
fi
+if test "${HAVE_HARFBUZZ}" = "yes" ; then
+ FONT_OBJ="$FONT_OBJ hbfont.o"
+fi
+AC_SUBST(FONT_OBJ)
AC_SUBST(XMENU_OBJ)
AC_SUBST(XOBJ)
AC_SUBST(FONT_OBJ)