summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2019-08-28 11:34:48 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2019-08-28 11:35:19 -0700
commitfdccab473e1f95dae5ee0f07a4531dd4e05b22dd (patch)
tree555e96a91fb725dd870f921a8d60cc9cb33251af /configure.ac
parente028131e05a12f13015b6b0cd8a41092850e43b8 (diff)
downloademacs-fdccab473e1f95dae5ee0f07a4531dd4e05b22dd.tar.gz
Don't worry about pre-1.0.0 alsa-lib include
Problem reported by Ergus in: https://lists.gnu.org/r/emacs-devel/2019-08/msg00563.html * configure.ac (ALSA_SUBDIR_INCLUDE): Do not define. * src/sound.c: Assume ALSA_SUBDIR_INCLUDE.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 0 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 6c83d61921e..e39a4380523 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1731,26 +1731,6 @@ if test "${with_sound}" != "no"; then
ALSA_MODULES="alsa >= $ALSA_REQUIRED"
EMACS_CHECK_MODULES([ALSA], [$ALSA_MODULES])
if test $HAVE_ALSA = yes; then
- SAVE_CFLAGS="$CFLAGS"
- SAVE_LIBS="$LIBS"
- CFLAGS="$ALSA_CFLAGS $CFLAGS"
- LIBS="$ALSA_LIBS $LIBS"
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <asoundlib.h>]], [[snd_lib_error_set_handler (0);]])],
- emacs_alsa_normal=yes,
- emacs_alsa_normal=no)
- if test "$emacs_alsa_normal" != yes; then
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <alsa/asoundlib.h>]],
- [[snd_lib_error_set_handler (0);]])],
- emacs_alsa_subdir=yes,
- emacs_alsa_subdir=no)
- if test "$emacs_alsa_subdir" != yes; then
- AC_MSG_ERROR([pkg-config found alsa, but it does not compile. See config.log for error messages.])
- fi
- ALSA_CFLAGS="$ALSA_CFLAGS -DALSA_SUBDIR_INCLUDE"
- fi
-
- CFLAGS="$SAVE_CFLAGS"
- LIBS="$SAVE_LIBS"
LIBSOUND="$LIBSOUND $ALSA_LIBS"
CFLAGS_SOUND="$CFLAGS_SOUND $ALSA_CFLAGS"
AC_DEFINE(HAVE_ALSA, 1, [Define to 1 if ALSA is available.])