summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Albinus <michael.albinus@gmx.de>2021-11-21 14:39:29 +0100
committerMichael Albinus <michael.albinus@gmx.de>2021-11-21 14:39:29 +0100
commit75d294cd4abb4d4062a1bfcd914229d0f9e142dd (patch)
tree2fd50e9b9f4d62bf1cbb0669aa4c3240cb4f145c /configure.ac
parent6d90444ba0f5202553cf8c245b809c09fce1a317 (diff)
downloademacs-75d294cd4abb4d4062a1bfcd914229d0f9e142dd.tar.gz
Reorganize emba control files
Using dynamic job generation in GitLab does not work sufficiently. So we generate the jobs in the Emacs sources. * configure.ac (SUBDIR_MAKEFILES): Add test/infra/Makefile. * test/Makefile.in (subdirs, generate-test-jobs): New targets. * test/infra/Makefile.in: * test/infra/test-jobs.yml: New files. * test/infra/default-gitlab-ci.yml: * test/infra/test-jobs-generator.sh: Remove. * test/infra/gitlab-ci.yml: Insert contents of default-gitlab-ci.yml. (stages): Remove generator and trigger. Add normal. (test-jobs-generator, test-jobs-pipeline): Remove jobs. (top): Include test-jobs.yml.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 90a487f7ac7..9cf192d4ba9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6309,6 +6309,13 @@ if test -f "$srcdir/$opt_makefile.in"; then
dnl ", [], [opt_makefile='$opt_makefile']" and it should work.
AC_CONFIG_FILES([test/Makefile])
fi
+opt_makefile=test/infra/Makefile
+if test -f "$srcdir/$opt_makefile.in"; then
+ SUBDIR_MAKEFILES="$SUBDIR_MAKEFILES $opt_makefile"
+ dnl Again, it's best not to use a variable. Though you can add
+ dnl ", [], [opt_makefile='$opt_makefile']" and it should work.
+ AC_CONFIG_FILES([test/infra/Makefile])
+fi
dnl The admin/ directory used to be excluded from tarfiles.