summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKévin Le Gouguec <kevin.legouguec@gmail.com>2021-12-19 14:58:41 +0100
committerLars Ingebrigtsen <larsi@gnus.org>2021-12-19 14:58:41 +0100
commit8535861430fc0ce82da73e01063ae11c85c65267 (patch)
tree68ae1db02827b44716541f4575cb8bfd048bbf27 /configure.ac
parentec692470bdbd9f673e925bae1c96ad066fb0295a (diff)
downloademacs-8535861430fc0ce82da73e01063ae11c85c65267.tar.gz
Enable webp support in PGTK builds, too
* configure.ac (HAVE_WEBP): Enable webp in PGTK builds, too.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 2e7ea2bd6fd..d1a433a5022 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2315,6 +2315,8 @@ dnl use the toolkit if we have gtk, or X11R5 or newer.
term_header=pgtkterm.h
with_gtk3=yes
USE_X_TOOLKIT=none
+ HAVE_PGTK=yes
+ AC_DEFINE([HAVE_PGTK], 1, [Define to 1 if you have pure Gtk+-3.])
;;
haiku )
term_header=haikuterm.h
@@ -2677,7 +2679,7 @@ HAVE_WEBP=no
if test "${with_webp}" != "no"; then
if test "${HAVE_X11}" = "yes" || test "${opsys}" = "mingw32" \
|| test "${HAVE_W32}" = "yes" || test "${HAVE_NS}" = "yes" \
- || test "${HAVE_BE_APP}" = "yes"; then
+ || test "${HAVE_BE_APP}" = "yes" || test "${HAVE_PGTK}" = "yes"; then
WEBP_REQUIRED=0.6.0
WEBP_MODULE="libwebp >= $WEBP_REQUIRED"
@@ -2950,8 +2952,6 @@ PGTK_LIBS=
if test "$window_system" = "pgtk"; then
PGTK_OBJ="pgtkfns.o pgtkterm.o pgtkselect.o pgtkmenu.o pgtkim.o xsettings.o"
PGTK_LIBS="$GTK_LIBS"
- HAVE_PGTK=yes
- AC_DEFINE([HAVE_PGTK], 1, [Define to 1 if you have pure Gtk+-3.])
fi
AC_SUBST(PGTK_OBJ)
AC_SUBST(PGTK_LIBS)